Build: #51 failed Manual run by Mark Goodrich

Build result summary

Details

Completed
Duration
5 minutes
Labels
None
Agent
Default Agent
Revisions
PIH Docker
e0c3074ee0fc8eacfa83ff549cea05226d07c9a4 e0c3074ee0fc8eacfa83ff549cea05226d07c9a4
endTB Bahmni Apps
aacf9d6b7220f26284e4ede223535727ca0bab17 aacf9d6b7220f26284e4ede223535727ca0bab17
Failing since
#50 (Manual run by Mark Goodrich)

No failed tests found, a possible compilation error occurred.

Responsible

This build has been failing since #50
No one has taken responsibility

Code commits

PIH Docker
Author Commit Message Commit date
mgoodrich <mark.goodrich@live.com> mgoodrich <mark.goodrich@live.com> e0c3074ee0fc8eacfa83ff549cea05226d07c9a4 e0c3074ee0fc8eacfa83ff549cea05226d07c9a4 back to Ubuntu 18.04

Error summary for release 0.89

The job generated some errors, drill down into the full build log for more details.

npm WARN deprecated grunt-filerev@0.2.1: Deprecated
npm WARN deprecated grunt-regarde@0.1.1: Deprecated in favor of grunt-contrib-watch which now have Livereload support built-in.
npm WARN deprecated grunt-rename@0.1.4: Deprecated
WARN engine karma@0.13.22: wanted: {"node":"0.10 || 0.12 || 4 || 5"} (current: {"node":"8.10.0","npm":"3.5.2"})
npm WARN deprecated coffee-script@1.3.3: CoffeeScript on NPM has moved to "coffeescript" (no hyphen)
npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm WARN deprecated jade@0.26.3: Jade has been renamed to pug, please install the latest version of pug instead of jade
npm WARN deprecated aws-sign@0.2.1: Incorrectly published ES6 version into the 0.x branch
WARN engine hawk@0.10.2: wanted: {"node":"0.8.x"} (current: {"node":"8.10.0","npm":"3.5.2"})
npm WARN deprecated node-uuid@1.4.8: Use uuid module instead
WARN engine cryptiles@0.1.3: wanted: {"node":"0.8.x"} (current: {"node":"8.10.0","npm":"3.5.2"})
WARN engine boom@0.3.8: wanted: {"node":"0.8.x"} (current: {"node":"8.10.0","npm":"3.5.2"})
WARN engine sntp@0.1.4: wanted: {"node":"0.8.x"} (current: {"node":"8.10.0","npm":"3.5.2"})
WARN engine hoek@0.7.6: wanted: {"node":"0.8.x"} (current: {"node":"8.10.0","npm":"3.5.2"})
npm WARN deprecated hoek@0.7.6: The major version is no longer supported. Please update to 4.x or newer
npm WARN deprecated graceful-fs@3.0.11: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.
npm WARN deprecated win-spawn@2.0.0: use [cross-spawn](https://github.com/IndigoUnited/node-cross-spawn) or [cross-spawn-async](https://github.com/IndigoUnited/node-cross-spawn-async) instead.
npm WARN deprecated istanbul@0.2.16: This module is no longer maintained, try this instead:
npm WARN deprecated   npm i nyc
npm WARN deprecated Visit https://istanbul.js.org/integrations for other alternatives.
npm WARN deprecated istanbul@0.3.22: This module is no longer maintained, try this instead:
npm WARN deprecated   npm i nyc
npm WARN deprecated Visit https://istanbul.js.org/integrations for other alternatives.
npm WARN deprecated coffee-script@1.8.0: CoffeeScript on NPM has moved to "coffeescript" (no hyphen)
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN prefer global istanbul@0.2.16 should be installed with -g
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.7
bower hustle#4e7e3bd                                 short-sha Consider using longer commit SHA to avoid conflicts
bower purl#2.3.1                                  invalid-meta for:/tmp/121e11f8e8556675d9994d538e88bfef/bower/35140a234585b4ec3d0babd645706056-67-S5Ssz5/bower.json
bower purl#2.3.1                                  invalid-meta The "description" is too long, the limit is 140 characters
bower ng-clip#0.2.5                               invalid-meta for:/tmp/121e11f8e8556675d9994d538e88bfef/bower/f6bfa2e355a1dfcdf37dc0e0fb4f9b85-67-rlmR8H/bower.json
bower ng-clip#0.2.5                               invalid-meta The "main" field cannot contain minified files
bower ngDialog#0.3.12                             invalid-meta for:/tmp/121e11f8e8556675d9994d538e88bfef/bower/195c3e0137369adf096fb038dd504a2d-67-phtOA7/bower.json
bower ngDialog#0.3.12                             invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes
bower ngDialog#0.3.12                             invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .css files: ["css/ngDialog.css","css/ngDialog-theme-default.css"]
bower jquery.scrollTo#*                           invalid-meta for:/tmp/121e11f8e8556675d9994d538e88bfef/bower/815e447f934b948a5a66c0c2bdabc1e8-67-fJw6kq/bower.json
bower jquery.scrollTo#*                           invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes
bower react#^15.3.2                               invalid-meta for:/tmp/121e11f8e8556675d9994d538e88bfef/bower/266a1f7c2e2345169d3bc448da45eae6-67-gPeaeY/bower.json
bower react#^15.3.2                               invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .js files: ["react.js","react-dom.js"]
bower ngReact#^0.3.0                              invalid-meta for:/tmp/121e11f8e8556675d9994d538e88bfef/bower/b4b132b4d95aaa9833aff148ba7fce5c-67-yYu95H/bower.json
bower ngReact#^0.3.0                              invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes
bower ngReact#^0.3.0                                  mismatch Version declared in the json (0.2.0) is different than the resolved one (0.3.0)
bower Cortana#~1.2.6                              invalid-meta for:/tmp/121e11f8e8556675d9994d538e88bfef/bower/fcd37535a505493ea50d64555425a8fb-67-IMd1J6/bower.json
bower Cortana#~1.2.6                              invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes
bower angular-file-upload#*                       invalid-meta for:/tmp/121e11f8e8556675d9994d538e88bfef/bower/e60440287b4df1cbc04045e77a8c05f5-67-ZXPDnq/bower.json
bower angular-file-upload#*                       invalid-meta The "main" field cannot contain minified files
bower Cortana#~1.2.6                                  mismatch Version declared in the json (1.2.8) is different than the resolved one (1.2.9)
bower zeroclipboard#~2.1.0                        invalid-meta for:/tmp/121e11f8e8556675d9994d538e88bfef/bower/a548dc9ab07e3f911d2d98f019e9515f-67-AnX5yQ/bower.json
bower zeroclipboard#~2.1.0                        invalid-meta The "description" is too long, the limit is 140 characters
bower select2#~3.4                                invalid-meta for:/tmp/121e11f8e8556675d9994d538e88bfef/bower/35368a19f307e4af02d0df055846840d-67-fgX3vp/bower.json
bower select2#~3.4                                invalid-meta The "main" field cannot contain font, image, audio, or video files
bower select2#~3.4                                invalid-meta The "main" field cannot contain font, image, audio, or video files
bower select2#~3.4                                invalid-meta The "main" field cannot contain font, image, audio, or video files
bower select2#~3.4                                invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .png files: ["select2.png","select2x2.png"]
bower jquery#1.9.1                                  deprecated Package jquery is using the deprecated component.json
bower jquery-ui#1.10.2                              deprecated Package jquery-ui is using the deprecated component.json
bower lovefield#~2.1.7                            invalid-meta for:/tmp/121e11f8e8556675d9994d538e88bfef/bower/488b97800547589db2bd261f6f381e1e-67-qzMWgg/bower.json
bower lovefield#~2.1.7                            invalid-meta The "main" field cannot contain minified files
(node:224) [DEP0022] DeprecationWarning: os.tmpDir() is deprecated. Use os.tmpdir() instead.
DEPRECATION WARNING on line 87 of /var/lib/gems/2.5.0/gems/compass-core-1.0.3/stylesheets/compass/css3/_deprecated-support.scss:
#{} interpolation near operators will be simplified in a future version of Sass.
To preserve the current behavior, use quotes:

  unquote('"$moz-"#{$experimental-support-for-mozilla} "$webkit-"#{$experimental-support-for-webkit} "$opera-"#{$experimental-support-for-opera} "$microsoft-"#{$experimental-support-for-microsoft} "$khtml-"#{$experimental-support-for-khtml}')

You can use the sass-convert command to automatically fix most cases.

DEPRECATION WARNING on line 92 of /var/lib/gems/2.5.0/gems/compass-core-1.0.3/stylesheets/compass/css3/_deprecated-support.scss:
#{} interpolation near operators will be simplified in a future version of Sass.
To preserve the current behavior, use quotes:

  unquote('"$ie6-"#{$legacy-support-for-ie6} "$ie7-"#{$legacy-support-for-ie7} "$ie8-"#{$legacy-support-for-ie8}')

You can use the sass-convert command to automatically fix most cases.

(node:289) [DEP0022] DeprecationWarning: os.tmpDir() is deprecated. Use os.tmpdir() instead.
(node:301) [DEP0022] DeprecationWarning: os.tmpDir() is deprecated. Use os.tmpdir() instead.